【対象バージョン】
2016.2, 2017.1, 2018.1, 2018.2, 2018.3, 2018.4.1-2018.4.6, 2019.4.1-2019.4.4
※2018.4.7~, 2019.4.5~, 2019.10, 2020.4 は手順が異なります。ガイドを参照ください。
スタンドアローンライセンスをオフライン ディアクティベーションできない
スタンドアローンライセンスをオフラインディアクティベーションできないという事象について説明します。
事象
- スタンドアローンライセンスのオフライン ディアクティベーションが正常に完了したように見受けられるものの、別端末でライセンスをアクティベーションしようとするとアクティベーション数超過エラー (Number of allowed activation exceeded ) が発生しアクティベーションができません。
- スタンドアローンライセンスをオフラインアクティベーション後、ご利用端末に OS のメジャーなアップデートを適用しています。
原因
スタンドアロンライセンスをオフライン アクティベーション後に OS のメジャーアップデートを適用すると、デバイス ID が変化してしまうことがあります。このデバイスID が変化した端末でオフライン ディアクティベーションを実行すると、端末からは正常にディアクティベーションされたように見受けられることがありますが、ライセンスサーバ上では、正常にディアクティベーションがされません。これは、ライセンスサーバの不具合により発生します。詳細は、Nalpeiron 社の INFORMATION BULLETIN August 20th 2019 「RE: Rare Offline Deactivation Issue identified」(英語)をご参照ください。
解決策
本事象は、2019年秋リリース予定の 2019 (LTS ーロングタームサポート) バージョンで修正予定となっております。
現在のところ、本事象に対する回避策はございません。
本事象が発生した場合は、次のうちいずれか2つ以上の情報をご提示の上カスタマーサポートにお問い合わせください:
- Device ID
- デバイス名
- アクティベーション時に登録したメールアドレス
UiPath カスタマーサポートお問い合わせ窓口 :